re = /(File "[^"]+?", line \d+, characters \d+-\d+):\n(Error|Warning): ([^]+?\.)\n\n/
str = 'File "./Solution.v", line 3, characters 2-13:
Error: In environment
n : nat
Unable to unify "n + 0" with "n".
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end