$re = '/(File "[^"]+?", line \d+, characters \d+-\d+):\n(Error|Warning): ([^]+?\.)\n\n/';
$str = 'File "./Solution.v", line 3, characters 2-13:
Error: In environment
n : nat
Unable to unify "n + 0" with "n".
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);