// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(File "[^"]+?", line \d+, characters \d+-\d+):\n(Error|Warning): ([^]+?\.)\n\n"#).unwrap();
let string = "File \"./Solution.v\", line 3, characters 2-13:
Error: In environment
n : nat
Unable to unify \"n + 0\" with \"n\".
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}