import re
regex = re.compile(r"(File \"[^\"]+?\", line \d+, characters \d+-\d+):\n(Error|Warning): ([^]+?\.)\n\n")
test_str = ("File \"./Solution.v\", line 3, characters 2-13:\n"
"Error: In environment\n"
"n : nat\n"
"Unable to unify \"n + 0\" with \"n\".\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")