import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(File \"[^\"]+?\", line \\d+, characters \\d+-\\d+):\\n(Error|Warning): ([^]+?\\.)\\n\\n";
final String string = "File \"./Solution.v\", line 3, characters 2-13:\n"
+ "Error: In environment\n"
+ "n : nat\n"
+ "Unable to unify \"n + 0\" with \"n\".\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}