#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(?\d{3}\)?\-?\d{3}\-?\d{4}$"
Local $sString = "999-999-9999" & @CRLF & _
"(123)123-1454" & @CRLF & _
"1234567890" & @CRLF & _
"(123)1231234" & @CRLF & _
"a122-123-1234" & @CRLF & _
"(123)-123-12345" & @CRLF & _
"(123)-(123)-(1234)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")