using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(?\d{3}\)?\-?\d{3}\-?\d{4}$";
string input = @"999-999-9999
(123)123-1454
1234567890
(123)1231234
a122-123-1234
(123)-123-12345
(123)-(123)-(1234)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}