re = /^\(?\d{3}\)?\-?\d{3}\-?\d{4}$/m
str = '999-999-9999
(123)123-1454
1234567890
(123)1231234
a122-123-1234
(123)-123-12345
(123)-(123)-(1234)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end