package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(?\d{3}\)?\-?\d{3}\-?\d{4}$`)
var str = `999-999-9999
(123)123-1454
1234567890
(123)1231234
a122-123-1234
(123)-123-12345
(123)-(123)-(1234)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}