import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(?\\d{3}\\)?\\-?\\d{3}\\-?\\d{4}$";
final String string = "999-999-9999\n"
+ "(123)123-1454\n"
+ "1234567890\n"
+ "(123)1231234\n"
+ "a122-123-1234\n"
+ "(123)-123-12345\n"
+ "(123)-(123)-(1234)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}