using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)\)|\[(?=[^]]*]))[^](]*\(([^)\\]*(?:\\.[^)\\]*)*)(?:\)[^(]*]TJ)?";
string substitution = @"$1";
string input = @"/TT0 1 Tf
0.002 Tc -0.002 Tw 11.04 0 0 11.04 221.16 707.04 Tm
[(\()-2(Y)7(o)7(u've )-3(g)7(o)-2(t )4(i)-3(t)(\))]TJ
EMC ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}