import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)\\)|\\[(?=[^]]*]))[^](]*\\(([^)\\\\]*(?:\\\\.[^)\\\\]*)*)(?:\\)[^(]*]TJ)?";
final String string = "/TT0 1 Tf\n"
+ "0.002 Tc -0.002 Tw 11.04 0 0 11.04 221.16 707.04 Tm\n"
+ "[(\\()-2(Y)7(o)7(u've )-3(g)7(o)-2(t )4(i)-3(t)(\\))]TJ\n"
+ "EMC ";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}