const regex = /(?:\G(?!\A)\)|\[(?=[^]]*]))[^](]*\(([^)\\]*(?:\\.[^)\\]*)*)(?:\)[^(]*]TJ)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)\\)|\\[(?=[^]]*]))[^](]*\\(([^)\\\\]*(?:\\\\.[^)\\\\]*)*)(?:\\)[^(]*]TJ)?', 'g')
const str = `/TT0 1 Tf
0.002 Tc -0.002 Tw 11.04 0 0 11.04 221.16 707.04 Tm
[(\\()-2(Y)7(o)7(u've )-3(g)7(o)-2(t )4(i)-3(t)(\\))]TJ
EMC `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);