import re
regex = re.compile(r"(?:\G(?!\A)\)|\[(?=[^]]*]))[^](]*\(([^)\\]*(?:\\.[^)\\]*)*)(?:\)[^(]*]TJ)?")
test_str = ("/TT0 1 Tf\n"
"0.002 Tc -0.002 Tw 11.04 0 0 11.04 221.16 707.04 Tm\n"
"[(\\()-2(Y)7(o)7(u've )-3(g)7(o)-2(t )4(i)-3(t)(\\))]TJ\n"
"EMC ")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)