#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)www\.youtube\.com\/watch\?v=(?<videoId>\S+)"
Local $sString = "www.youtube.com/watch?v=NsjeEt1ZpqQ" & @CRLF & _
"https://www.youtube.com/channel/UCKqFqiCe1dCUxRe0_YNZ6gg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")