re = /www\.youtube\.com\/watch\?v=(?<videoId>\S+)/m
str = 'www.youtube.com/watch?v=NsjeEt1ZpqQ
https://www.youtube.com/channel/UCKqFqiCe1dCUxRe0_YNZ6gg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end