package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)www\.youtube\.com\/watch\?v=(?<videoId>\S+)`)
var str = `www.youtube.com/watch?v=NsjeEt1ZpqQ
https://www.youtube.com/channel/UCKqFqiCe1dCUxRe0_YNZ6gg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}