const regex = /www\.youtube\.com\/watch\?v=(?<videoId>\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('www\\.youtube\\.com\\\/watch\\?v=(?<videoId>\\S+)', 'gm')
const str = `www.youtube.com/watch?v=NsjeEt1ZpqQ
https://www.youtube.com/channel/UCKqFqiCe1dCUxRe0_YNZ6gg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}