import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "www\\.youtube\\.com\\/watch\\?v=(?<videoId>\\S+)";
final String string = "www.youtube.com/watch?v=NsjeEt1ZpqQ\n"
+ "https://www.youtube.com/channel/UCKqFqiCe1dCUxRe0_YNZ6gg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}