using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"www\.youtube\.com\/watch\?v=(?<videoId>\S+)";
string input = @"www.youtube.com/watch?v=NsjeEt1ZpqQ
https://www.youtube.com/channel/UCKqFqiCe1dCUxRe0_YNZ6gg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}