using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{2,6})[\s\D]*([0-9]{1,6})[\s\D]*((20){0,1}([0-9]{2}))$";
string input = @"pagamento fattura 003235 2071/2022
pagamento fattura 003235/cli 2071/2022
pagamento fattura 003235-cli 2071-2022
pagamento fattura 003235 2071-2022
pagamento fattura 003235 cli 2071 2022
pagamento fattura 003235 2071 2022
pagamento fattura 003235 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/22";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}