use strict;
my $str = 'pagamento fattura 003235 2071/2022
pagamento fattura 003235/cli 2071/2022
pagamento fattura 003235-cli 2071-2022
pagamento fattura 003235 2071-2022
pagamento fattura 003235 cli 2071 2022
pagamento fattura 003235 2071 2022
pagamento fattura 003235 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/22';
my $regex = qr/([0-9]{2,6})[\s\D]*([0-9]{1,6})[\s\D]*((20){0,1}([0-9]{2}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}