import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{2,6})[\\s\\D]*([0-9]{1,6})[\\s\\D]*((20){0,1}([0-9]{2}))$";
final String string = "pagamento fattura 003235 2071/2022\n"
+ "pagamento fattura 003235/cli 2071/2022\n"
+ "pagamento fattura 003235-cli 2071-2022\n"
+ "pagamento fattura 003235 2071-2022\n"
+ "pagamento fattura 003235 cli 2071 2022\n"
+ "pagamento fattura 003235 2071 2022\n"
+ "pagamento fattura 003235 2071 del 20/12/2022\n"
+ "pagamento fattura cliente 003235 nr. 2071 del 20/12/2022\n"
+ "pagamento fattura cliente 003235 nr. 2071 del 20/12/22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}