import Foundation
let pattern = #"([0-9]{2,6})[\s\D]*([0-9]{1,6})[\s\D]*((20){0,1}([0-9]{2}))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
pagamento fattura 003235 2071/2022
pagamento fattura 003235/cli 2071/2022
pagamento fattura 003235-cli 2071-2022
pagamento fattura 003235 2071-2022
pagamento fattura 003235 cli 2071 2022
pagamento fattura 003235 2071 2022
pagamento fattura 003235 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/22
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)