# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[monitor:\/\/\/var\/log\/(?:messages|secure|cron|spooler|audit\.log)\](?:(?:\R.*){2})index=).*/$1whatever/gm;t' <<< "[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power"