import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[monitor:///var/log/(?:messages|secure|cron|spooler|audit\\.log)\\](?:(?:\\R.*){2})index=).*";
final String string = "[monitor:///var/log/messages]\n"
+ "sourcetype=linux\n"
+ "index=power\n\n"
+ "[monitor:///var/log/secure]\n"
+ "sourcetype=linux\n"
+ "index=power";
final String subst = "$1whatever";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}