const regex = new RegExp('(\\[monitor:///var/log/(?:messages|secure|cron|spooler|audit\\.log)\\](?:(?:\\R.*){2})index=).*', 'gm')
const str = `[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power`;
const subst = `$1whatever`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);