#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\[monitor:///var/log/(?:messages|secure|cron|spooler|audit\.log)\](?:(?:\R.*){2})index=).*"
Local $sString = "[monitor:///var/log/messages]" & @CRLF & _
"sourcetype=linux" & @CRLF & _
"index=power" & @CRLF & _
"" & @CRLF & _
"[monitor:///var/log/secure]" & @CRLF & _
"sourcetype=linux" & @CRLF & _
"index=power"
Local $sSubst = "$1whatever"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)