import Foundation
let pattern = #"(\[monitor:///var/log/(?:messages|secure|cron|spooler|audit\.log)\](?:(?:\R.*){2})index=).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1whatever"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)