$re = '`(\[monitor:///var/log/(?:messages|secure|cron|spooler|audit\.log)\](?:(?:\R.*){2})index=).*`m';
$str = '[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power';
$subst = "$1whatever";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;