#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[!file(?:\s*title="([^"]*?)"\s*icon="([^"]*?)")?]\(([^)]+)\)"
Local $sString = "// from this: [!file title="This is my title" icon="rocket"](file.txt)" & @CRLF & _
"" & @CRLF & _
"attributes = [" & @CRLF & _
" "title" : "This is my title"," & @CRLF & _
" "icon" : "rocket"," & @CRLF & _
" "item" : "file.txt"" & @CRLF & _
"]" & @CRLF & _
"" & @CRLF & _
"or from this: [!file](../files/docs/terms.pdf)" & @CRLF & _
"" & @CRLF & _
"attributes = [" & @CRLF & _
" "title" : ""," & @CRLF & _
" "icon" : ""," & @CRLF & _
" "item" : "../files/docs/terms.pdf"" & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")