// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[!file(?:\s*title="([^"]*?)"\s*icon="([^"]*?)")?]\(([^)]+)\)"#).unwrap();
let string = "// from this: [!file title=\"This is my title\" icon=\"rocket\"](file.txt)
attributes = [
\"title\" : \"This is my title\",
\"icon\" : \"rocket\",
\"item\" : \"file.txt\"
]
or from this: [!file](../files/docs/terms.pdf)
attributes = [
\"title\" : \"\",
\"icon\" : \"\",
\"item\" : \"../files/docs/terms.pdf\"
]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}