use strict;
my $str = '// from this: [!file title="This is my title" icon="rocket"](file.txt)
attributes = [
"title" : "This is my title",
"icon" : "rocket",
"item" : "file.txt"
]
or from this: [!file](../files/docs/terms.pdf)
attributes = [
"title" : "",
"icon" : "",
"item" : "../files/docs/terms.pdf"
]';
my $regex = qr/\[!file(?:\s*title="([^"]*?)"\s*icon="([^"]*?)")?]\(([^)]+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}