# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[!file(?:\s*title=\"([^\"]*?)\"\s*icon=\"([^\"]*?)\")?]\(([^)]+)\)"
test_str = ("// from this: [!file title=\"This is my title\" icon=\"rocket\"](file.txt)\n\n"
"attributes = [\n"
" \"title\" : \"This is my title\",\n"
" \"icon\" : \"rocket\",\n"
" \"item\" : \"file.txt\"\n"
"]\n\n"
"or from this: [!file](../files/docs/terms.pdf)\n\n"
"attributes = [\n"
" \"title\" : \"\",\n"
" \"icon\" : \"\",\n"
" \"item\" : \"../files/docs/terms.pdf\"\n"
"]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.