using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[!file(?:\s*title=""([^""]*?)""\s*icon=""([^""]*?)"")?]\(([^)]+)\)";
string input = @"// from this: [!file title=""This is my title"" icon=""rocket""](file.txt)
attributes = [
""title"" : ""This is my title"",
""icon"" : ""rocket"",
""item"" : ""file.txt""
]
or from this: [!file](../files/docs/terms.pdf)
attributes = [
""title"" : "",
""icon"" : "",
""item"" : ""../files/docs/terms.pdf""
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}