re = /\[!file(?:\s*title="([^"]*?)"\s*icon="([^"]*?)")?]\(([^)]+)\)/m
str = '// from this: [!file title="This is my title" icon="rocket"](file.txt)
attributes = [
"title" : "This is my title",
"icon" : "rocket",
"item" : "file.txt"
]
or from this: [!file](../files/docs/terms.pdf)
attributes = [
"title" : "",
"icon" : "",
"item" : "../files/docs/terms.pdf"
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end