package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<elementIdentifier>\.F)\/(?<airlineandFlightNumber>[A-Z0-9]{2,3}[A-Z0-9]{3,4})\/(?<date>[0-9]{2}[A-Z]{3})\/(?<destinationAirportCode>[A-Z]{3})\/?(?<classOfTravelOfBaggage>[A-Z0-9]{1})?`)
var str = `.F/SR101/16APR/JFK/J
.F/AF0703/04JAN/CDG/Y
.F/AF0703/04JAN/CDG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}