$re = '/(?<elementIdentifier>\.F)\/(?<airlineandFlightNumber>[A-Z0-9]{2,3}[A-Z0-9]{3,4})\/(?<date>[0-9]{2}[A-Z]{3})\/(?<destinationAirportCode>[A-Z]{3})\/?(?<classOfTravelOfBaggage>[A-Z0-9]{1})?/m';
$str = '.F/SR101/16APR/JFK/J
.F/AF0703/04JAN/CDG/Y
.F/AF0703/04JAN/CDG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);