import Foundation
let pattern = #"(?<elementIdentifier>\.F)\/(?<airlineandFlightNumber>[A-Z0-9]{2,3}[A-Z0-9]{3,4})\/(?<date>[0-9]{2}[A-Z]{3})\/(?<destinationAirportCode>[A-Z]{3})\/?(?<classOfTravelOfBaggage>[A-Z0-9]{1})?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.F/SR101/16APR/JFK/J
.F/AF0703/04JAN/CDG/Y
.F/AF0703/04JAN/CDG
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)