use strict;
my $str = '.F/SR101/16APR/JFK/J
.F/AF0703/04JAN/CDG/Y
.F/AF0703/04JAN/CDG';
my $regex = qr/(?<elementIdentifier>\.F)\/(?<airlineandFlightNumber>[A-Z0-9]{2,3}[A-Z0-9]{3,4})\/(?<date>[0-9]{2}[A-Z]{3})\/(?<destinationAirportCode>[A-Z]{3})\/?(?<classOfTravelOfBaggage>[A-Z0-9]{1})?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}