re = /(?<elementIdentifier>\.F)\/(?<airlineandFlightNumber>[A-Z0-9]{2,3}[A-Z0-9]{3,4})\/(?<date>[0-9]{2}[A-Z]{3})\/(?<destinationAirportCode>[A-Z]{3})\/?(?<classOfTravelOfBaggage>[A-Z0-9]{1})?/m
str = '.F/SR101/16APR/JFK/J
.F/AF0703/04JAN/CDG/Y
.F/AF0703/04JAN/CDG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end