use strict;
my $str = '<A HREF="UID50B5C7EEF789AB44AECFF">Origen 1 2 </A>Tarea 1 2<A HREF="UIDD034051C4B77FA419DC48">Nombre Apellido</A>
';
my $regex = qr/<([^>]+)>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}