// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<([^>]+)>").unwrap();
let string = "<A HREF=\"UID50B5C7EEF789AB44AECFF\">Origen 1 2 </A>Tarea 1 2<A HREF=\"UIDD034051C4B77FA419DC48\">Nombre Apellido</A>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}