$re = '/<([^>]+)>/m';
$str = '<A HREF="UID50B5C7EEF789AB44AECFF">Origen 1 2 </A>Tarea 1 2<A HREF="UIDD034051C4B77FA419DC48">Nombre Apellido</A>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);