import re
regex = re.compile(r"<([^>]+)>", flags=re.MULTILINE)
test_str = ("<A HREF=\"UID50B5C7EEF789AB44AECFF\">Origen 1 2 </A>Tarea 1 2<A HREF=\"UIDD034051C4B77FA419DC48\">Nombre Apellido</A>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")