re = /<([^>]+)>/m
str = '<A HREF="UID50B5C7EEF789AB44AECFF">Origen 1 2 </A>Tarea 1 2<A HREF="UIDD034051C4B77FA419DC48">Nombre Apellido</A>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end