# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[.,])(?=[^\s])/ /g;t' <<< "line = \"This is a text.This is another text,it has no space after the comma.\"
"