import Foundation
let pattern = #"(?<=[.,])(?=[^\s])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
line = "This is a text.This is another text,it has no space after the comma."
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)