re = /(?<=[.,])(?=[^\s])/
str = 'line = "This is a text.This is another text,it has no space after the comma."
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result