$re = '/(?<=[.,])(?=[^\s])/';
$str = 'line = "This is a text.This is another text,it has no space after the comma."
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;